Just the Facts——阶乘计算

  Just the Facts 

The expression  N !, read as ``  N  factorial," denotes the product of the first  N  positive integers, where  N  is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ( $0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer  N , you should read the value and compute the last nonzero digit of  N !.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value  N , right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``  ->  " (space hyphen greater space). Column 10 must contain the single last non-zero digit of  N !.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8


题意:给出一个数,求这个数的阶乘,输出阶乘结果从低位开始,第一个不为零的数。

一个数无论和多大的数相乘,得出结果的最后几位只需要用该数和大数的最后几位相乘得出。

解析:打表直接输出不就好了?可是long long到了20的阶乘之后就会超范围了,不过存储能够用到的范围内的数不就好了。还是直接上代码吧,感觉挺简单的,也就不能说什么了。

#include <stdio.h>
#include <string.h>

long long f[10009];

void init()
{
    f[0] = 1;
    f[1] = 1;
    f[2] = 2;
    long long i;
    for(i = 3;i <= 10000;i++)
    {
        long long ji = i * f[i - 1];
        long long yu = ji % 10;
        ji = ji / 10;
        while(!yu)
        {
            yu = ji % 10;
            ji = ji / 10;
        }
        ji = ji * 10 + yu;
        f[i] = ji % 1000000;
    }
}

int main()
{
    init();
    long long i;
    while(~scanf("%lld",&i))
    {
        printf("%5lld -> %lld\n",i,f[i] % 10);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值