HDU ACM1052 —— Tian Ji -- The Horse Racing

41 篇文章 0 订阅
2 篇文章 0 订阅

Tian Ji – The Horse Racing

Problem Description
Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

在这里插入图片描述

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0
0

思路:田忌赛马大家都知道,就是一种贪心算法。基本思路就是用自己最强赢敌方能赢的里面最厉害的,以此来建立优势。
(1)首先比较两者最快的马,如果田忌的马本就比国王快,那就直接比。
(2)如果不快则再比较两者最慢的马,能赢就比。
(3)如果上面都赢不了,则用田忌最慢的换国王最大的。
(4)经过多次比赛后,田忌最慢的马可能与国王最快的马一样快,直接过。
例:田:88 77 66 66 66
王:99 89 77 66 66
无论怎样,比较都只有n次。
第一次:66 换99
第二次:66 换89
第三次:由于国王77是最大的 88 赢77
第四次:77赢66
第五次:只剩下最后的田66(按顺序是第三个) 与 王66(最后一个),相比直接过。

#include<stdio.h>
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int a[2001]={0},b[2001]={0},i,j;
		if(n==0)break; 
		int con=0; 
		for(i=0;i<n;i++)scanf("%d",&a[i]);
		for(i=0;i<n;i++)scanf("%d",&b[i]);
		/*将两者的马按速度从快到慢排序*/
		for(i=0;i<n;i++){
			for(j=0;j<n;j++){
				if(b[j]<b[j+1]){
					int m=b[j];
					b[j]=b[j+1];
					b[j+1]=m;
				}
			}
		}
		for(i=0;i<n;i++){
			for(j=0;j<n;j++){
				if(a[j]<a[j+1]){
					int m=a[j];
					a[j]=a[j+1];
					a[j+1]=m;
				}
			}
		}
		int ai=0,aj=n-1,bi=0,bj=n-1;/*ai指a[]中目前的的最快的马,aj指最慢的,以此类推*/
		for(i=0;i<n;i++){
			if(a[ai]>b[bi]){	/*两人最快马相比*/ 
				ai++;bi++;con++;
			}
			else if(a[aj]>b[bj]){	/*两人最慢马相比*/ 
				aj--;bj--;con++;
			}
			else if(a[aj]<b[bi]){	/*田最慢与王最快*/ 
				aj--;bi++;con--;
			}
			else if(a[aj]==b[bi]){	/*两马速度相同时*/ 
				aj--;bi++;
			}
		}
		printf("%d\n",con*200);
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值