POJ-1080:Human Gene Functions


Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20239 Accepted: 11299

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

Source


概译:给出两个基因序列,可以随意插入‘-’把他们补成等长,然后根据题中给出的列表计算相似度分数(将两个补完的串上下对齐,对齐的两个字符到表里查找得分,然后加和),尽量求最大分数。例如 AGTGATG 和 GTTAG就可以补成AGTGAT-G  和 -GT--TAG  这样得到的分数是 (-3)+5+5+(-2)+(-3)+5+(-3)+5=9
但更好的一种是AGTGATG 和 -GTTA-G  ,得到 (-3)+5+5+(-2)+5+(-1) +5=14分。

输入第一行为测试组数,随后每组给出两个串,每个串先给长度后给串。
运用了动态规划的思想,因为是字符串所以类似于最长公共子序列的想法,详见代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int value[5][5]={5,-1,-2,-1,-3,
				 -1,5,-3,-2,-4,
				 -2,-3,5,-2,-2,
				 -1,-2,-2,5,-1,
				 -3,-4,-2,-1,0};
int dp[101][101];
int change(char c)
{
	switch(c)//与表相对应,可以用于查找 
	{
		case 'A':return 0;
		case 'C':return 1;
		case 'G':return 2;
		case 'T':return 3;
		case ' ':return 4;
	}
}
int main()
{
	int x;
	cin>>x;//x组数据 
	while(x--)
	{
		int m,n;
		string s,t;
		//输入长度和串
		cin>>m>>s; 
		cin>>n>>t;
		//初始化0分 
		memset(dp,0,sizeof(dp));
		//当其中一个为空之时,为边界情况 
		for(int i=1;i<=m;i++)
			dp[i][0]=dp[i-1][0]+value[change(s[i-1])][change(' ')];
		for(int i=1;i<=n;i++)
			dp[0][i]=dp[0][i-1]+value[change(t[i-1])][change(' ')];
			
		for(int i=1;i<=m;i++)
			for(int j=1;j<=n;j++)
				dp[i][j]=max(dp[i-1][j-1]+value[change(s[i-1])][change(t[j-1])],max(dp[i-1][j]+value[change(s[i-1])][change(' ')],dp[i][j-1]+value[change(t[j-1])][change(' ')]));
				//当前s和当前t对位    当前的s和空格对位、t和s上一个对位    当前的t和空格对位、s和t的上一个对位	 这三种情况选最大值 
		printf("%d\n",dp[m][n]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值