Flip Game

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:在4x4的方格内放置了一些黑白棋子,b代表黑色,w代表白色,翻转一个棋子则它四个方向的棋子(如果存在棋子的话)都得翻个个儿,问至少几次翻转使所有的棋子都为黑色或都为白色。输出次数。

思路:这个题是深搜题,从右下角开始搜,将其四个方向(如果存在棋子的话)都翻个个儿,然后算一下黑子或白子的个数,如果等于零或等于16对minn进行一个更新。代码如下:

#include<stdio.h>
#include<string.h>
int flag,minn=99999999;
void angel(int n,int k,char a[10][10])
{
    int i,j,sum=0;
    char b[10][10];
    for(i=0; i<4; i++)
    {
        for(j=0; j<4; j++)
        {
            if(a[i][j]=='b')
                sum++;
        }
    }
    if(sum==16||sum==0)
    {
        if(k<minn)
        {
            flag=1;
            minn=k;
        }
        return ;
    }
    if(n==16)
        return ;
    for(i=0; i<4; i++)
        strcpy(b[i],a[i]);
    angel(n+1,k,b);
    int x=n/4;
    int y=n%4;
    if(b[x][y]=='b')
        b[x][y]='w';
    else
        b[x][y]='b';
    if(y>=1)
    {
        if(b[x][y-1]=='b')
            b[x][y-1]='w';
        else
            b[x][y-1]='b';
    }
    if(y<=2)
    {
        if(b[x][y+1]=='b')
            b[x][y+1]='w';
        else
            b[x][y+1]='b';
    }
    if(x>=1)
    {
        if(b[x-1][y]=='b')
            b[x-1][y]='w';
        else
            b[x-1][y]='b';
    }
    if(x<=2)
    {
        if(b[x+1][y]=='b')
            b[x+1][y]='w';
        else
            b[x+1][y]='b';
    }
    angel(n+1,k+1,b);
}
int main()
{
    flag=0;
    char a[10][10];
    for(int i=0; i<4; i++)
        scanf("%s",a[i]);
    angel(0,0,a);
    if(flag==1)
        printf("%d\n",minn);
    else
        printf("Impossible\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
pygame.transform.flip() is a method in the Pygame library that is used to flip an image along its axis. This method can be used to create mirror images or to change the orientation of an image. The method takes three arguments: the image to be flipped, a boolean value indicating whether to flip the image horizontally, and a boolean value indicating whether to flip the image vertically. Syntax: ``` pygame.transform.flip(surface, xbool, ybool) ``` - surface: The image to be flipped. - xbool: A boolean value indicating whether to flip the image horizontally (True or False). - ybool: A boolean value indicating whether to flip the image vertically (True or False). Example: ``` import pygame pygame.init() # Set up the display display_width = 640 display_height = 480 game_display = pygame.display.set_mode((display_width, display_height)) # Load the image my_image = pygame.image.load("image.png") # Flip the image horizontally flipped_image = pygame.transform.flip(my_image, True, False) # Display the original and flipped images game_display.blit(my_image, (0, 0)) game_display.blit(flipped_image, (display_width/2, 0)) pygame.display.update() # Quit the game pygame.quit() ``` In the above example, we first load an image using the `pygame.image.load()` method. We then use the `pygame.transform.flip()` method to create a flipped version of the image by passing in `True` as the first argument to indicate that we want to flip the image horizontally. We then display both the original and flipped images using the `blit()` method. Finally, we update the display and quit the game.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值