Play on Words

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题意:输入一组单词,判定是否可以通过重组使每个单词第一个字母跟前一个单词的最后一个字母相同。

思路:本题中,每个单词可以看成连接首尾两个字母的一条又向边(由首字母指向尾子母),这样可以构成一个图了,构成图后,题中判定是否可以通过重组使每个单词第一个字母跟前一个单词最后一个字母相同,等效于判断图中是否存在一条路径经过每条边一次且仅一次,这就是有向欧拉通路,还要判断整个有向图是否能联通,判断连通的话用并查集,所以如果这组数据既连通了又可以构成欧拉通路,那么就是成立的,代码如下:

#include<stdio.h>
#include<string.h>
#include<math.h>
int f[30];
int getf(int v)
{
    if(f[v] == -1)
        return v;
    else
    {
        f[v] = getf(f[v]);
        return(f[v]);
    }
}
void merge(int u,int v)
{
    int t1 = getf(u);
    int t2 = getf(v);
    if(t1 != t2)
        f[t2] =t1;
}
char str[1010];
int in[30],out[30];
int main()
{
    int T,n,len,u,v,flag,p,q,i;
    scanf("%d",&T);
    while(T--)
    {
        flag=1;
        scanf("%d",&n);
        memset(f,-1,sizeof(f));  //初始化为-1
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        int s = -1;
        while(n--)
        {
            scanf("%s",str);
            len=strlen(str);
            u=str[0]-'a';     // 首尾
            v=str[len-1]-'a';
            merge(u,v);
            out[u]++; //首字母加1,尾字母入度加一
            in[v]++;
            if(s==-1)
                s=u;
        }
    //满足欧拉回路的条件
    //所有节点入度等于出度
    //或者只有1个点入度比出度小1一个点出度比入度小1,其余节点出度等于入度。
        p=0;
        q=0;
        for(i=0; i<26; i++)
        {
            if(out[i]-in[i]==1)
                p++;
            else if(out[i]-in[i]==-1)
                q++;
            else if(out[i]!=in[i])
                flag = 0;
            if(out[i]||in[i])
                if(getf(i)!=getf(s))
                    flag=0;
        }
        if(!((p==0&&q==0)||(p==1&&q==1)))
            flag =0;
        if(flag==1)
        printf("Ordering is possible.\n");
        else
        printf("The door cannot be opened.\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
图像识别技术在病虫害检测中的应用是一个快速发展的领域,它结合了计算机视觉和机器学习算法来自动识别和分类植物上的病虫害。以下是这一技术的一些关键步骤和组成部分: 1. **数据收集**:首先需要收集大量的植物图像数据,这些数据包括健康植物的图像以及受不同病虫害影响的植物图像。 2. **图像预处理**:对收集到的图像进行处理,以提高后续分析的准确性。这可能包括调整亮度、对比度、去噪、裁剪、缩放等。 3. **特征提取**:从图像中提取有助于识别病虫害的特征。这些特征可能包括颜色、纹理、形状、边缘等。 4. **模型训练**:使用机器学习算法(如支持向量机、随机森林、卷积神经网络等)来训练模型。训练过程中,算法会学习如何根据提取的特征来识别不同的病虫害。 5. **模型验证和测试**:在独立的测试集上验证模型的性能,以确保其准确性和泛化能力。 6. **部署和应用**:将训练好的模型部署到实际的病虫害检测系统中,可以是移动应用、网页服务或集成到智能农业设备中。 7. **实时监测**:在实际应用中,系统可以实时接收植物图像,并快速给出病虫害的检测结果。 8. **持续学习**:随着时间的推移,系统可以不断学习新的病虫害样本,以提高其识别能力。 9. **用户界面**:为了方便用户使用,通常会有一个用户友好的界面,显示检测结果,并提供进一步的指导或建议。 这项技术的优势在于它可以快速、准确地识别出病虫害,甚至在早期阶段就能发现问题,从而及时采取措施。此外,它还可以减少对化学农药的依赖,支持可持续农业发展。随着技术的不断进步,图像识别在病虫害检测中的应用将越来越广泛。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值