1043. Is It a Binary Search Tree (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1043

题目:



时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

分析:

知道前序,其实还知道中序(就是排序后的),然后再看后序。还要注意树中有两个相同的结点的情况,后者把树调换后需要倒着来找rootIdx。

AC代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string>
using namespace std;
struct Node{
 int i;
 Node *lchild;
 Node *rchild;
}Tree[1002];
int loc;
int str1[1002];//前序
int str2[1002];//中序
int ans[1002];//ans
bool cmp(int x, int y){
 return x > y;
}
Node *creat(){
 Tree[loc].lchild = Tree[loc].rchild = NULL;
 return &Tree[loc++];
}
int idx = 0;
void postOrder(Node *T){
 if (T->lchild != NULL){
  postOrder(T->lchild);
 }
 if (T->rchild != NULL){
  postOrder(T->rchild);
 }
 ans[idx++] = T->i;
}
Node* build(int s1, int e1, int s2, int e2){
 if (e1 - s1 != e2 - s2)return NULL;
 Node *ret = creat();
 ret->i = str1[s1];
 int rootIdx = -1;
 for (int i = s2; i <= e2; i++){
  if (str2[i] == str1[s1]){
   rootIdx = i;
   break;
  }
 }
 if (rootIdx == -1)return NULL;
 if (rootIdx != s2){
  ret->lchild = build(s1 + 1, s1 + (rootIdx - s2), s2, rootIdx - 1);
 }
 if (rootIdx != e2){
  ret->rchild = build(s1 + (rootIdx - s2) + 1, e1, rootIdx + 1, e2);
 }
 return ret;
}
Node* newbuild(int s1, int e1, int s2, int e2){
 if (e1 - s1 != e2 - s2)return NULL;
 Node *ret = creat();
 ret->i = str1[s1];
 int rootIdx = -1;
 for (int i = e2; i >= s2; i--){
  if (str2[i] == str1[s1]){
   rootIdx = i;
   break;
  }
 }
 if (rootIdx == -1)return NULL;
 if (rootIdx != s2){
  ret->lchild = build(s1 + 1, s1 + (rootIdx - s2), s2, rootIdx - 1);
 }
 if (rootIdx != e2){
  ret->rchild = build(s1 + (rootIdx - s2) + 1, e1, rootIdx + 1, e2);
 }
 return ret;
}
void change(Node *T){
 Node *tmp = T->rchild;
 T->rchild = T->lchild;
 T->lchild = tmp;
 if (T->lchild != NULL)change(T->lchild);
 if (T->rchild != NULL)change(T->rchild);
}
int main(){
 //freopen("F://Temp/input.txt", "r", stdin);
 int n;
 cin >> n;
 for(int i = 0; i < n; i++){
  cin >> str1[i];
  str2[i] = str1[i];
 }
 sort(str2, str2 + n);
 loc = 0;
 Node *T = build(0, n - 1, 0, n - 1);
 postOrder(T);
 if (idx < n){//再倒过来找一遍,为了应对有连个相同结点的情况。
  sort(str2, str2 + n, cmp );
  idx = 0;
  T = newbuild(0, n - 1, 0, n - 1);
  postOrder(T);
 }
 if (idx == n){
  cout << "YES" << endl;
  for (int i = 0; i < n; i++){
   if (i == 0)cout << ans[i];
   else cout << " " << ans[i];
  }
 }
 else cout << "NO";
 cout << endl;
 return 0;
}


截图:


——Apie陈小旭

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【Solution】 To convert a binary search tree into a sorted circular doubly linked list, we can use the following steps: 1. Inorder traversal of the binary search tree to get the elements in sorted order. 2. Create a doubly linked list and add the elements from the inorder traversal to it. 3. Make the list circular by connecting the head and tail nodes. 4. Return the head node of the circular doubly linked list. Here's the Python code for the solution: ``` class Node: def __init__(self, val): self.val = val self.prev = None self.next = None def tree_to_doubly_list(root): if not root: return None stack = [] cur = root head = None prev = None while cur or stack: while cur: stack.append(cur) cur = cur.left cur = stack.pop() if not head: head = cur if prev: prev.right = cur cur.left = prev prev = cur cur = cur.right head.left = prev prev.right = head return head ``` To verify the accuracy of the code, we can use the following test cases: ``` # Test case 1 # Input: [4,2,5,1,3] # Output: # Binary search tree: # 4 # / \ # 2 5 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 <-> 4 <-> 5 # Doubly linked list in reverse order: 5 <-> 4 <-> 3 <-> 2 <-> 1 root = Node(4) root.left = Node(2) root.right = Node(5) root.left.left = Node(1) root.left.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) # Test case 2 # Input: [2,1,3] # Output: # Binary search tree: # 2 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 # Doubly linked list in reverse order: 3 <-> 2 <-> 1 root = Node(2) root.left = Node(1) root.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) ``` The output of the test cases should match the expected output as commented in the code.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值