Eddy's research I
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 11390 Accepted Submission(s): 7057
Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .
Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
11
9412
Sample Output
11
2*2*13*181
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
#define inf 65540
int vis[inf];
int mat[inf];
void prim()//素数打表
{
vis[0]=vis[1]=1;
int m=sqrt(inf+0.5);
for(int i=2;i<=m;i++)
{
if(!vis[i])
{
for(int j=i*i;j<=inf;j+=i)
{
vis[j]=1;
}
}
}
return ;
}
int main()
{
int n,m;
prim();
while(~scanf("%d",&n))
{
m=0;
memset(vis,0,sizeof(vis));
for(int i=2;i<=n;i++)
{
if(!vis[i]&&(n%i==0))//是素数且为因子
{
while(n%i==0)//看有多少个该因子
{
mat[m++]=i;
n/=i;
}
}
}
for(int i=0;i<m-1;i++)//输出
printf("%d*",mat[i]);
printf("%d\n",mat[m-1]);
}
return 0;
}