HDU 1085 Holding Bin-Laden Captive! (母函数)

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24475    Accepted Submission(s): 10894

Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
 
 
1 1 3
0 0 0
 

Sample Output
 
 
4

母函数,了解一下:传送门     传送门2  这两个博客就可以看懂了,尤其是第一个。这个题可以当做母函数模板

/*这种是有限张数的组合,假如每种纸币都有无限张,那么一定会有询问的范围 
就将这个范围最大值当做最大值MAX,即MAX=N;那么将改为j<=N;j+K<=N。  
*/  
#include<cstdio>  
#include<cstring>  
typedef long long LL;  
const int N = 1000 * (1+2+5) + 5;
//最多每种1000张,则要开的数组为可能的最大钱数   
int cost[3] = {1, 2, 5};//三种面值纸币   
LL c1[N], c2[N];
//c2是临时合并的多项式,每次清零;c1是最终合并的多项式,保存的是每个组合的方案数   
int num[3];  
int MAX;  
int main()
{  
    while(~scanf("%d%d%d", &num[0], &num[1], &num[2]))
	{//每个面值的钱有多少张
        if(num[0] == 0 && num[1] == 0 && num[2] == 0) break;  
        memset(c1, 0, sizeof(c1));//初始化   
        memset(c2, 0, sizeof(c2));  
        MAX = num[0] + num[1] * 2 + num[2] * 5;//计算这些钱能组成的最大值。边界   
        c1[0] = 1;//一开始0的情况算一种  
        for(int i = 0; i < 3; i ++)
		{//三种纸币   
            for(int j = 0; j <= num[i] * cost[i]; j += cost[i])
			{//第i种面值的纸币,步长为cost[i]  
                for(int k = 0; j + k <= MAX; k ++)
				{  
                    c2[j + k] += c1[k];  
                }  
            }   
            for(int j = 0; j < N; j ++)
			{//把c2的数据抄到c1,清空c2  
                c1[j] = c2[j];  
                c2[j] = 0;  
            }  
        }  
        for(int i = 1; i <= MAX + 1; i ++)
		{  
            if(!c1[i])
			{//为零,代表没有可能   
                printf("%d\n", i);  
                break;  
            }  
        }  
    }  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值