最大子数列和+动态处理 1007 Maximum Subsequence Sum (25分)

1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N
​1
​​ , N
​2
​​ , …, N
​K
​​ }. A continuous subsequence is defined to be { N
​i
​​ , N
​i+1
​​ , …, N
​j
​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解题
一次遍历求得该数列的最大子数列和,并且记录最大子数列的头和尾;

#include<iostream>
using namespace std;

int N;
int Num[10001];

void input()
{
	cin>>N;
	for(int i=0;i<N;i++)
	cin>>Num[i];
}

int Sum=0;
int MAXSUM=-1;    //判断是不是全为负
int head;
int tail;
int temp; 

void Find()
{
	temp=Num[0];
	for(int i=0;i<N;i++)
	{
		Sum+=Num[i];
		if(Sum>MAXSUM)        //大于则
		{
			MAXSUM=Sum;
			head=temp;
			tail=Num[i];
		}
        else if(Sum<0)    //不大于最大值,而且小于0
		{
			Sum=0;
			temp=Num[i+1];
		}
	}
}

int main()
{
	input();
	Find();
    if(MAXSUM<0)
    cout<<"0 "<<Num[0]<<" "<<Num[N-1];
	else 
    cout<<MAXSUM<<" "<<head<<" "<<tail;
}

注意点
1.因为要区别全负和有负数有0,所以MAXSUM需要初始化为-1;
2.初始化这三个变量时要在main函数或者函数内,不能再全局函数初始化,因为那时Num还没有被赋值;

temp=Num[0];
head=Num[0];
tail=Num[N-1];

3.else if;

方法
遍历数组,记录SUM,当SUM为负时舍弃前面的数,从一下个重新开始记录SUM,并把下一个数保存在temp中,若后续SUM大于先前的MAXSUM,则更新head和tail;
因为有全负的判断,所以head和tail无需赋予初值;

#include<iostream>
using namespace std;

int N;
int Num[10001];

void input()
{
	cin>>N;
	for(int i=0;i<N;i++)
	cin>>Num[i];
	
}

int Sum=0;
int MAXSUM=-1;    //判断是不是全为负
int head;
int tail;
int temp=0; 

void Find()
{
	for(int i=0;i<N;i++)
	{
		Sum+=Num[i];
		if(Sum>MAXSUM)        //大于则
		{
			MAXSUM=Sum;
			head=Num[temp];
			tail=Num[i];
		}
        else if(Sum<0)    //不大于最大值,而且小于0
		{
			Sum=0;
			temp=i+1;
		}
	}
}

int main()
{
	input();
	Find();
    if(MAXSUM<0)
    cout<<"0 "<<Num[0]<<" "<<Num[N-1];
	else 
    cout<<MAXSUM<<" "<<head<<" "<<tail;
}

python

 #算法4改版
N=int(input())
A=list(map(int,input().split()))       #输入int

def MaxSubseqSum1( A, N):
    Maxsum=-1
    thissum=0
    x=A[0]
    y=A[-1]
    x1=0
    for i in range(N):
        thissum+=A[i]          #向右累加,若为负数,则必抛弃前面的数
            
            #删除k循环
        if thissum> Maxsum:     
            Maxsum=thissum
            x=A[x1]
            y=A[i]
            
        elif thissum<0:            #归零——相当于从后面累加
            thissum=0
            x1=i+1
    if Maxsum<0:
        print(0,A[0],A[-1])
    else:
        print(Maxsum,x,y)
#复杂度为O(N)——不便于理解
MaxSubseqSum1(A,N)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值