双向图链式存储+统计最大连通子图 +多输出输出 1013 Battle Over Cities (25分)

23 篇文章 0 订阅

1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city
​1
​​ -city
​2
​​ and city
​1
​​ -city
​3
​​ . Then if city
​1
​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city
​2
​​ -city
​3
​​ .

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

解题
先建图,求删除图中一个点(包括连接这个点的边)后,图的最大连通子图数量;
建图使用链式储存(vector代替动态链表),这样删除结点较容易;

注意点
没有说明边的数量和查询的数量,若很大的话会有大量输入输出,用printf和scanf才不会超时;

1.输入函数(包括建图)

#include<iostream>
#include<vector>
#include<queue>
using namespace std;

vector<vector<int>> Graph;
int N,M,K;
void input()
{
	//cin>>N>>M>>K;
	scanf("%d %d %d",&N,&M,&K);
	Graph.resize(N+1);
	int city1,city2;
	for(int i=0;i<M;i++)
	{
		//cin>>city1>>city2;
		scanf("%d %d",&city1,&city2);
		Graph[city1].push_back(city2);     //从1开始保存 
		Graph[city2].push_back(city1);
	}
	//链表保存图 
 } 

2.计算函数,因为用链式储存,所以BFS计算更方便,使用队列;

传入图数组和要删除的结点序号,返回需要建立的边数(剩余连通子图数-1);
BFS处理时跳过被删除的city即可(传入引用节省空间和时间)。

int RoadNum(vector<vector<int>> &Graph,int city)
{
	Graph[city].clear();
	int cnt=-1;
	int visited[N+1]={0};
	
	queue<int> P;
	  //从第一座城市开始
	for(int i=1;i<=N;i++) 
	{
		if(!visited[i]&&i!=city){
		visited[i]=1;
		P.push(i);
		while(!P.empty())
		{
			int tmp=P.front();
			P.pop();
			for(int t:Graph[tmp]){
				if(t==city||visited[t]) continue;
				P.push(t);
				visited[t]=1;
			}
		}
		cnt++;
	}
	}
	return cnt;
}

3.输出函数,得到每一个要查询的city,输出要建立的边数;

void output()
{
	int city;
	for(int i=0;i<K;i++)
		{
			//cin>>city;
			scanf("%d",&city);
			printf("%d\n",RoadNum(Graph,city));
			//cout<<RoadNum(Graph,city)<<endl;
		}
}

4.main函数

int main()
{
	input();
	output();
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值