Red and Black(POJ:1979)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include<stdio.h>
char map[21][21];
int book[21][21];//用book数组记录是否走过该点
int W, H;
int cont;
void dfs(int x, int y)
{
	int next[4][2] = {
		{0,1},{1,0},{0,-1},{-1,0}
	                  };//记录上下左右的移动
	int gx, gy;
	for (int k = 0; k <= 3; k++)
	{
		gx = x + next[k][0];
		gy = y + next[k][1];
		if (gx<1 || gx>H || gy<1 || gy>W || map[gx][gy] == '#')
			continue;
		if (book[gx][gy] == 0 && map[gx][gy] == '.')//寻找并记录未走过的点
		{
			book[gx][gy] = 1;//将已走的点标记为1
			cont++;
			dfs(gx, gy);//从改点接着继续深搜
		}
	}
	return;//回到上次函数调用,换个方向继续寻找
}
int main()
{
	int i, j;
	while (scanf("%d%d", &W, &H),W!=0&&H!=0)
	{
		cont = 1;
		for (i = 1; i <= H; i++)
		{
			getchar();//读取缓存中的回车以防被当做字符处理
			for (j = 1; j <= W; j++)
			{
				char s;
				scanf("%c", &s);
				map[i][j] = s;
				book[i][j] = 0;
			}
		}
			for(i=1; i<=H; i++)
				for (j = 1; j <= W; j++)
				{
					//从初始位置开始进行深搜,并将初始位置标记已走
					if (map[i][j] == '@')
					{
						book[i][j] = 1;
						dfs(i,j);
					}
				}	
			printf("%d\n", cont);
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值