Oil Deposits(POJ:1562)

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2
#include<stdio.h>
char map[110][110];
int m, n;
int next[8][2] = { {0,1},{1,0},{0,-1},{-1,0},{1,1},{1,-1},{-1,-1},{-1,1} };//记录八个方向
int count;
void dfs(int x, int y)
{
	map[x][y] = '*';//将这个小油坑进行标记,下次不再计数
	int i, j, k;
	for (k = 0; k <= 7; k++)//查找附近的八个点
	{
		int nx = x + next[k][0];
		int ny = y + next[k][1];
		if (map[nx][ny] == '@')//如果在附近找到小油坑
		{
			dfs(nx, ny);
		}
	}
	return;//如果附近不再有返回前一个点的附近接着寻找
}
int main()
{
	while (scanf("%d%d", &m, &n), m != 0)
	{
		int i, j;
		count = 0;
		for (i = 0; i < m; i++)
			scanf("%s", map[i]);
		for (i = 0; i < m; i++)
			for (j = 0; j < n; j++)
			{
				if (map[i][j] == '@')//找到第一个小油坑开始深搜
				{
					dfs(i, j);//当第一个连通着的小油坑找完后计数一个并接着找下一个小油坑接着深搜
					count++;
				}
			}
		printf("%d\n", count);
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值