Rescue ZOJ

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)


Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.


Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."


Sample Input

7 8 
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........


Sample Output

13

这道题比普通的BFS多了一点,要想到达一个地方可能还需要多花费一个时间杀死守卫,所以最短步数不一定就是最短时间,在这里定义一个最小时间数组mintime,记录到达每一点的最小时间,初始化为INF,然后不断更新,整个BFS过程结束后,返回到达终点的mintime
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#define INF 1e7    //最大距离

using namespace std;
const int N = 250;

struct node
{
    int x, y, time;   //坐标,时间
};
char map[N][N];
int mintime[N][N];    //存放到达每个点的最少时间
int n, m;
int si, sj, ei, ej;
int xx[4] = {-1, 0, 1, 0};
int yy[4] = {0, 1, 0, -1};

int BFS()
{
    queue<node> q;
    struct node t, u;
    t.x = si;
    t.y = sj;
    t.time = 0;
    q.push(t);
    mintime[si][sj] = 0;
    while(!q.empty())
    {
        u = q.front();
        q.pop();
        for(int i = 0; i < 4; i++)
        {
            t.x = u.x + xx[i];
            t.y = u.y + yy[i];
            if(t.x >= 0 && t.x < n && t.y >= 0 && t.y < m && map[t.x][t.y] != '#')
            {
                t.time = u.time + 1;
                if(map[t.x][t.y] == 'x')  //如果遇到守卫,多花费一个时间来消灭
                    t.time ++;
                if(t.time < mintime[t.x][t.y])  
                {
                    mintime[t.x][t.y] = t.time;  //更新最小时间
                    q.push(t);
                }
            }
        }
    }
    return mintime[ei][ej];  //返回到达终点的最小时间
}
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        for(int i = 0; i < n; i++)
            scanf("%s", map[i]);
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                mintime[i][j] = INF;
                if(map[i][j] == 'a')
                {
                    si = i;
                    sj = j;
                }
                else if(map[i][j] == 'r')
                {
                    ei = i;
                    ej = j;
                }
            }
        }
        int t = BFS();
        if(t < INF)
            printf("%d\n", t);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值