hdu1071 2010.3.5

hdu1071 2010.3.5

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2175    Accepted Submission(s): 1401

 

Problem Description

Ignatius bought a land last week, but hedidn't know the area of the land because the land is enclosed by a parabola anda straight line. The picture below shows the area. Now given all theintersectant points shows in the picture, can you tell Ignatius the area of theland?

 

Note: The point P1 in the picture is thevertex of the parabola. 


 

Input

The input contains several test cases. Thefirst line of the input is a single integer T which is the number of testcases. T test cases follow.

Each test case contains three intersectantpoints which shows in the picture, they are given in the order of P1, P2, P3.Each point is described by two floating-point numbers X andY(0.0<=X,Y<=1000.0).

 

Output

For each test case, you should output thearea of the land, the result should be rounded to 2 decimal places.

 

Sample Input

2

5.000000 5.000000

0.000000 0.000000

10.000000 0.000000

10.000000 10.000000

1.000000 1.000000

14.000000 8.222222

 

 

Sample Output

33.33

40.69

 

Hint

For float may be not accurate enough,please use double instead of float.

 

Author

Ignatius.L

#include <stdio.h>
#include <math.h>

double x1,x2,x3,y11,y2,y3,k,b,a;
int i,t;

double fun(double x)
{
    return (a*x*x*x/3)-(a*x1+k/2)*x*x+(a*x1*x1+y11-b)*x;
}

void main()
{
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        scanf("%lf %lf %lf %lf %lf %lf",&x1,&y11,&x2,&y2,&x3,&y3);
        a=(y2-y11)/(x2-x1)/(x2-x1);
        k=(y2-y3)/(x2-x3);
        b=y2-k*x2;
        printf("%.2lf\n",fun(x3)-fun(x2));
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值