hdu1158 2010.3.5

hdu1158 2010.3.5

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1081    Accepted Submission(s): 381

 

 

Problem Description

A project manager wants to determine thenumber of the workers needed in every month. He does know the minimal number ofthe workers needed in each month. When he hires or fires a worker, there willbe some extra cost. Once a worker is hired, he will get the salary even if heis not working. The manager knows the costs of hiring a worker, firing aworker, and the salary of a worker. Then the manager will confront such aproblem: how many workers he will hire or fire each month in order to keep thelowest total cost of the project.

 

 

 

Input

The input may contain several data sets.Each data set contains three lines. First line contains the months of theproject planed to use which is no more than 12. The second line contains thecost of hiring a worker, the amount of the salary, the cost of firing a worker.The third line contains several numbers, which represent the minimal number ofthe workers needed each month. The input is terminated by line containing asingle '0'.

 

 

 

Output

The output contains one line. The minimaltotal cost of the project.

 

 

 

Sample Input

3

4 5 6

10 9 11

0

 

 

Sample Output

199

 

 

Source

Asia 1997, Shanghai(Mainland China)

 

 

Recommend

Ignatius


#include<stdio.h>
int a[15];
int f[15][1001];
int main()
{
    int month,i,j,k,max,min;
    int hire,salary,fire;
    for(;;)
    {
        scanf("%d",&month);getchar();
        if(month==0) break;
        max=0;
        scanf("%d %d %d",&hire,&salary,&fire);getchar();
        for(i=1;i<=month;i++)
        {
            scanf("%d",&a[i]);getchar();
            if(a[i]>max) max=a[i];
        }
        for(i=a[1];i<=max;i++)
            f[1][i]=(hire+salary)*i;
        for(i=2;i<=month;i++)
            for(j=a[i];j<=max;j++)
            {
                f[i][j]=0x1FFFFFFF;
                for(k=a[i-1];k<=max;k++)
                {
                    if(j<k)
                    {
                        if(f[i-1][k]+fire*(k-j)+j*salary<f[i][j])
                            f[i][j]=f[i-1][k]+fire*(k-j)+j*salary;
                    }
                    else if(j==k)
                    {
                        if(f[i-1][k]+salary*j<f[i][j])
                            f[i][j]=f[i-1][k]+salary*j;
                    }
                    else if(j>k)
                    {
                        if(f[i-1][k]+hire*(j-k)+salary*j<f[i][j])
                            f[i][j]=f[i-1][k]+hire*(j-k)+salary*j;
                    }
                }
            }
        min=f[month][a[month]];
        for(i=a[month]+1;i<=max;i++)
            if(f[month][i]<min)
                min=f[month][i];
        printf("%d\n",min);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值