hdu1977 2010.3.5

hdu1977 2010.3.5

Consecutive sum II

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 476    Accepted Submission(s): 247

 

 

Problem Description

Consecutive sum come again. Are you ready?Go ~~

1   = 0 + 1

2+3+4   = 1 + 8

5+6+7+8+9 = 8 + 27

You can see the consecutive sum can berepresenting like that. The nth line will have 2*n+1 consecutive numbers on theleft, the first number on the right equal with the second number in last line,and the sum of left numbers equal with two number’s sum on the right.

Your task is that tell me the right numbersin the nth line.

 

 

 

Input

The first integer is T, and T lines willfollow.

Each line will contain an integer N (0<= N <= 2100000).

 

 

 

Output

For each case, output the right numbers inthe Nth line.

All answer in the range of signed 64-bitsinteger.

 

 

 

Sample Input

3

0

1

2

 

 

Sample Output

0 1

1 8

8 27

 

 

Author

Wiskey

 

 

Source

2008杭电集训队选拔赛

 

 

Recommend

wangye


#include <stdio.h>

void main()
{
    int i,t;
    __int64 a,b,x;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        scanf("%I64d",&a);
        x=a*a*a;
        b=(a+1)*(a+1)*(a+1);
        printf("%I64d %I64d\n",x,b);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值