Tautology(永真式:状态压缩和递归)

Tautology

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

代码如下:

#include <stdio.h>
#include <string.h>
char data[10005];
int value;
int position = 0;
int getValue()
{
    switch(data[position++])
    {
        bool t1,t2;
    case 'p':
        return (value & (1 << 0));
    case 'q':
        return (value & (1 << 1));
    case 'r':
        return (value & (1 << 2));
    case 's':
        return (value & (1 << 3));
    case 't':
        return (value & (1 << 4));
    case 'N':
        return !getValue();
    case 'K':
        return getValue() & getValue();
    case 'A':
        return getValue() | getValue();
    case 'C':
        return (!getValue()|getValue());
    case 'E':
        return (!(getValue()^getValue()));
    }
}
int main()
{
    while(~scanf("%s", data)&&data[0]!='0')
    {
        for(value = 0; value < (1 << 5); value++)
        {
            position = 0;
            if(getValue() == 0)
            {
                printf("not\n");
                break;
            }
        }
        if(value >= (1 << 5)) printf("tautology\n");
    }
    return 0;
}

状态压缩方程讲解

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值