D - Find The Multiple(BFS)

D - Find The Multiple


题目

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

输入

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

输出

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

样例输入

2
6
19
0

样例输出

10
100100100100100100
111111111111111111

思路
对我来说,比赛时第一道难关就是对英文题目的翻译与题意的理解。
由于我在英语学习上的造诣,所以读(kan)懂(fan)题(yi)还是很轻松的。
在这里插入图片描述

这道题主要是说,给出数字n,输出一个只有0,1构成的能够整除数字n的数字,当输入为0时结束输入。

由于是在简单搜索专题里遇见的,所以思路还是比较清晰的。

首先我们要想:
如果当前的数tmp不符合条件,那么下一个数取谁?怎么得到这个数?

举个例子,当tmp=1时不符合条件,那么我们下一个数有两个选择:10,11(01还是1,不考虑)

10=1*10=tmp*10   

11=1*10+1=tmp*10+1

自己可以多举几个例子来理解此式。

所以我们得到了BFS的"移动方式”:

q.push(tmp*10);
q.push(tmp*10+1);

核心讲过剩下的就简单了,「伊丽莎白」!
在这里插入图片描述

#define _CRT_SBCURE_NO_DEPRECATE
#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
using namespace std;
typedef long long ll;
ll n;                  //数据开成long long不会爆掉
void BFS()
{
    queue<ll>q;
    q.push(1);         //1作为起点,0就没必要了
    while(!q.empty())
    {
        ll tmp=q.front();
        q.pop();
        if(tmp%n==0)
        {
            cout<<tmp<<endl;
            return ;
        }
        q.push(tmp*10);
        q.push(tmp*10+1);
    }
}
int main()
{
    ios::sync_with_stdio(false);   //cin,cout不加速会T掉
    cin.tie(0);
    cout.tie(0);
    while(cin>>n&&n)
    {
        BFS();
    }
}

搜索题主要是思想,没有固定代码。

又是快乐的一天。
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值