DFS模板题HDU1016

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input

n (0 < n < 20).

 

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

https://i-blog.csdnimg.cn/blog_migrate/427b1dd2282412709d583cc17eda983e.gif

 

Sample Input

 

6 8

 

 

Sample Output

 

Case 1: 1 4 3 2 5 6

1 6 5 2 3 4

Case 2: 1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

 

代码:

//该题思路简单,精髓在于对回溯与数组的灵活使用
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
bool vis[25];
int num[25],sum,n;

bool is_prime(int x,int y)//判素数
{
	int k=x+y;
	if(k==1)	return false;
	for(int i=2;i*i<=k;i++)
		if(k%i==0)	return false;
	return true;
}
void dfs(int sum)
{
	if(sum>n)
		{
			if(is_prime(num[1],num[n]))//如果头尾相加为素数,说明可行
				{
					for(int i=1;i<n;i++)
						printf("%d ",num[i]);
					printf("%d\n",num[n]);
				}
		}
	for(int i=2;i<=n;i++)
		{
			if(is_prime(i,num[sum-1])&&!vis[i])
				{
					vis[i]=1;
					num[sum]=i;
					dfs(sum+1);
					vis[i]=0;//回溯
				}
		}
}

int main()
{
	int cnt=0;
	while(~scanf("%d",&n))
		{
			memset(vis,0,sizeof(vis));
			vis[1]=1,num[1]=1;//初始化
			printf("Case %d:\n",++cnt);
			dfs(2);
			printf("\n");
		}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值