PAT-A1065 A+B and C (64bit) 题目内容及题解

Given three integers A, B and C in [−2^​63​​,2^​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题目大意

题目给出若干个样例,分别为A、B和C,题目要求判断A+B是否大于C,并输出结果。

解题思路

  1. 由于题目给定的数据范围,用long long类型存储数据并计算;
  2. 输出结果并返回零值。

代码

#include<stdio.h>
int main(){
    long long a,b,c;
    int T,i;
    scanf("%d",&T);
    for(i=1;i<=T;i++){
        printf("Case #%d: ",i);
        scanf("%lld%lld%lld",&a,&b,&c);
        if(b>c-a){
            printf("true");
        }else{
            printf("false");
        }
        printf("\n");
    }
    return 0;
}

运行结果

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值