PAT-A1058 A+B in Hogwarts 题目内容及题解

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​^7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

题目大意

题目给定一种特殊的货币进制,要求在这样的进制下计算两个数字的和,并将结果按该进制输出。

解题思路

  1. 模拟算数加法从地位到高位逐次运算;
  2. 输出结果并返回零值。

代码

#include<stdio.h>
int main(){
    int G1,G2,G3,S1,S2,S3,K1,K2,K3;
    scanf("%d.%d.%d %d.%d.%d",&G1,&S1,&K1,&G2,&S2,&K2);
    K3=(K1+K2)%29;
    S3=(K1+K2)/29;
    S3=S3+S1+S2;
    G3=S3/17;
    S3=S3%17;
    G3=G1+G2+G3;
    printf("%d.%d.%d\n",G3,S3,K3);
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是一个简单的 Page Object Model 的代码示例: ```python from selenium.webdriver.common.by import By from selenium.webdriver.support.ui import WebDriverWait from selenium.webdriver.support import expected_conditions as EC class WelcomePage: def __init__(self, driver): self.driver = driver def is_title_matches(self): """检查页面标题是否匹配""" return "PetClinic" in self.driver.title def get_started_button(self): """获取 Get started 按钮""" return WebDriverWait(self.driver, 10).until( EC.element_to_be_clickable((By.CSS_SELECTOR, 'a.btn-primary'))) def click_get_started(self): """点击 Get started 按钮""" get_started_button = self.get_started_button() get_started_button.click() class LoginPage: def __init__(self, driver): self.driver = driver def is_title_matches(self): """检查页面标题是否匹配""" return "PetClinic" in self.driver.title def get_username_field(self): """获取用户名输入框""" return self.driver.find_element_by_id("username") def get_password_field(self): """获取密码输入框""" return self.driver.find_element_by_id("password") def get_login_button(self): """获取登录按钮""" return self.driver.find_element_by_css_selector("button[type='submit']") def login(self, username, password): """登录""" username_field = self.get_username_field() password_field = self.get_password_field() login_button = self.get_login_button() username_field.clear() username_field.send_keys(username) password_field.clear() password_field.send_keys(password) login_button.click() ``` 在这个示例中,我们定义了两个 Page Object:WelcomePage 和 LoginPage。WelcomePage 用于描述欢迎页面,LoginPage 用于描述登录页面。每个 Page Object 都有自己的方法,用于访问和操作该页面的元素。这些方法封装了对元素的定位和操作,使测试代码更加清晰和易于维护。在测试代码中,我们只需要创建相应的 Page Object 实例,并调用其方法来访问和操作页面元素,而无需关心元素的具体定位方式和操作细节。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值