PAT-A1093/B1040 Count PAT's/有几个PAT 题目内容及题解

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

字符串 APPAPT 中包含了两个单词 PAT,其中第一个 PAT 是第 2 位(P),第 4 位(A),第 6 位(T);第二个 PAT 是第 3 位(P),第 4 位(A),第 6 位(T)。

现给定字符串,问一共可以形成多少个 PAT?

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

输入只有一行,包含一个字符串,长度不超过10​5​​,只包含 P、A、T 三种字母。

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

在一行中输出给定字符串中包含多少个 PAT。由于结果可能比较大,只输出对 1000000007 取余数的结果。

Sample Input:

APPAPT

Sample Output:

2

解题思路

直接数会超时,因此采用其他方法计数:

  1. 从左向右数‘P’的字符数,并逐个记录;
  2. 从右向左数‘T’的字符数,并逐个记录;
  3. 从左向右遍历,每当读到‘A’时,将对应位置的‘P’和‘T’的计数器结果相乘并加入总和、取余;
  4. 输出结果并返回零值。

代码

#include<stdio.h>
#include<string.h>
#define maxn 100010
int Pnum[maxn],Tnum[maxn];
int sum;
int main(){
    int i,len,count;
    char str[maxn];
    scanf("%s",str);
    len=strlen(str);
    count=0;
    for(i=0;i<len;i++){
        Pnum[i]=count;
        if(str[i]=='P'){
            count++;
        }
    }
    count=0;
    for(i=len-1;i>=0;i--){
        Tnum[i]=count;
        if(str[i]=='T'){
            count++;
        }
    }
    for(i=0;i<len;i++){
        if(str[i]=='A'){
            sum+=Pnum[i]*Tnum[i];
            sum%=1000000007;
        }
    }
    printf("%d\n",sum);
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值