PAT-A1109/B1055 Group Photo/集体照 题目内容及题解

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  • All the people in the rear row must be no shorter than anyone standing in the front rows;
  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

拍集体照时队形很重要,这里对给定的 N 个人 K 排的队形设计排队规则如下:

  • 每排人数为 N/K(向下取整),多出来的人全部站在最后一排;
  • 后排所有人的个子都不比前排任何人矮;
  • 每排中最高者站中间(中间位置为 m/2+1,其中 m 为该排人数,除法向下取整);
  • 每排其他人以中间人为轴,按身高非增序,先右后左交替入队站在中间人的两侧(例如5人身高为190、188、186、175、170,则队形为175、188、190、186、170。这里假设你面对拍照者,所以你的左边是中间人的右边);
  • 若多人身高相同,则按名字的字典序升序排列。这里保证无重名。

现给定一组拍照人,请编写程序输出他们的队形。

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10​^4​​), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

每个输入包含 1 个测试用例。每个测试用例第 1 行给出两个正整数 N(≤10​^4​​,总人数)和 K(≤10,总排数)。随后 N 行,每行给出一个人的名字(不包含空格、长度不超过 8 个英文字母)和身高([30, 300] 区间内的整数)。

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

输出拍照的队形。即K排人名,其间以空格分隔,行末不得有多余空格。注意:假设你面对拍照者,后排的人输出在上方,前排输出在下方。

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

解题思路

  1. 读入学生数据并将其排序;
  2. 计算每列人数;
  3. 模拟将数字填入每列中;
  4. 按题目要求格式输出并返回零值。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int N,K;
int first,rest;
struct Person{
    char name[20];
    int height;
}P[20010];

int G[12][10010];

bool cmp(Person a,Person b){
    if(a.height!=b.height){
        return a.height>b.height;
    }else{
        return strcmp(a.name,b.name)<0;
    }
}

void Init(){
    int i;
    scanf("%d%d",&N,&K);
    for(i=0;i<N;i++){
        scanf("%s %d",P[i].name,&P[i].height);
    }
    sort(P,P+N,cmp);
    rest=N/K;
    first=N-rest*(K-1);
}

void Op(){
    int i,j;
    int seq=0;
    int left,right;
    left=first/2,right=first/2;
    if(seq<N){
        G[0][left]=seq++;
    }
    for(j=1;j<first;j++){
        if(j%2){
            G[0][--left]=seq++;
        }else{
            G[0][++right]=seq++;
        }
    }
    for(i=1;i<K;i++){
        left=rest/2,right=rest/2;
        if(seq<N){
            G[i][left]=seq++;
        }   
        for(j=1;j<rest;j++){
            if(j%2){
                G[i][--left]=seq++;
            }else{
                G[i][++right]=seq++;
            }
        }
    }
}

void Print(){
    int i,j;
    for(j=0;j<first;j++){
        printf("%s",P[G[0][j]].name);
        if(j<first-1){
            printf(" ");
        }
    }
    printf("\n");
    for(i=1;i<K;i++){
        for(j=0;j<rest;j++){
            printf("%s",P[G[i][j]].name);
            if(j<rest-1){
                printf(" ");
            }
        }
        printf("\n");
    }
}

int main(){
    Init();
    Op();
    Print();
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值