PAT-A1129 Recommendation System 题目内容及题解

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题目大意

题目给定一个访问序列,并要求根据序列和推荐信息编写一个非常简单的推荐系统,该系统根据该用户访问某个条目的次数从第二个选项开始对该用户的待选项进行排序,并在每次搜索后输出待选项信息。

解题思路

  1. 用结构体储存节点和推荐列表;
  2. 用book和inq数组记录信息;
  3. 读入第一个记录并将其加入队列;
  4. 从第二个记录开始执行循环:输出当前队列信息,更新book数组,判断该新纪录是否在推荐列表内后用不同方式通过book数组的内容更新推荐列表内的信息,并重新排序;如果当前推荐列表内容大于规定值,则末尾元素出队并标记;
  5. 执行结束后返回零值。

代码

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
#define maxn 50010

struct Node{
    int data,frequency;
};

bool cmp(Node a,Node b){
    if(a.frequency!=b.frequency){
        return a.frequency>b.frequency;
    }else{
        return a.data<b.data;
    }
}
vector<Node> seq;
int N,K;
int book[maxn],inq[maxn];

void Insert(int v){
    int i,num=0;
    Node temp;
    printf("%d:",v);
    for(i=0;i<seq.size()&&i<K;i++){
        printf(" %d",seq[i].data);
    }
    printf("\n");
    //print
    book[v]++;
    if(inq[v]==0){//不在队内 
        temp.data=v;
        temp.frequency=book[v];
        seq.push_back(temp);
        inq[v]=1;
    }else{
        for(i=0;i<seq.size();i++){
            if(seq[i].data==v){
                seq[i].frequency=book[v];
            }
        }
    }
    sort(seq.begin(),seq.end(),cmp);
    if(seq.size()>K){
        inq[seq[K].data]=0;
        seq.pop_back();
    }
}

int main(){
    int a;
    Node temp;
    scanf("%d%d",&N,&K);
    N--;
    scanf("%d",&a);
    temp.data=a;
    book[a]++;
    temp.frequency=book[a];
    seq.push_back(temp);
    inq[a]=1;
    while(N--){
        scanf("%d",&a);
        Insert(a);
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值