A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3820 Accepted Submission(s): 1351
 
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output

            For each test case, you should output two lines. The first line is \\\\\\\"Case #:\\\\\\\", # means the number of the test case. The second line is the an equation \\\\\\\"A + B = Sum\\\\\\\", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
      
      
#include <stdio.h>
#include <string.h>
#include<iostream>
using namespace std;
int main()
{
    int i,n,j,t,xt,zt;
    char z[10000],x[10000],v[10000]={0};
    char a;
    cin>>n;
    int tt=n;
    j=1;
    while(n--)
    {
        cin>>z>>x;
        cout<<"Case "<<j<<":"<<endl<<z<<" + "<<x<<" = ";
        zt=strlen(z);
        xt=strlen(x);
        for(i=0;i<zt/2;i++)//将字符串倒置  从后往前
        {
            a=z[i];
            z[i]=z[zt-1-i];
            z[zt-1-i]=a;
        }
        for(i=0;i<xt/2;i++)
        {
            a=x[i];
            x[i]=x[xt-1-i];
            x[xt-1-i]=a;
        }
        for(i=0;i<zt;i++)//转化为数字
        {
            z[i]-='0';
        }
        for(i=0;i<xt;i++)
        {
            x[i]-='0';
        }
        if(zt>xt)
            t=zt;
        else
            t=xt;
        for(i=0;i<t;i++)
        {
            if(i<zt)v[i]+=z[i];
            if(i<xt)v[i]+=x[i];
            if(v[i]>=10)
            {
                v[i]=v[i]%10;v[i+1]++;//是否需要进位
            }
        }
        if(v[t]!=0)
             t=t+1;
        for(i=t-1;i>=0;i--)
           { 
                printf("%d",v[i]);
                v[i]=0;
            }
        cout<<endl;
        if(j!=tt)cout<<endl;
        j++;
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值