How Many Trees?

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1365 Accepted Submission(s): 722
 
Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
 
Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 
Output
You have to print a line in the output for each entry with the answer to the previous question.
 
Sample Input
1
2
3
 
Sample Output
1
2
5
/*卡特兰公式的一个应用就是用来求“给出n个节点,问能够成多少棵二叉树”。
an =C(2n,n)/(n+1)=(4n-2)*(an-1 )/(n+1)*/
#include<iostream>
#include<cstdio>
#include<cstring>
int h[1001][1001];
int Catlan()
{
    memset(h,0,sizeof(h));
    h[1][0]=1;
    h[1][1]=1;
    h[2][0]=1;
    h[2][1]=2;
    for(int i=3;i<=101;i++)
    {
        int len=h[i-1][0];
        for(int j=1;j<=len;j++)
             {
                    h[i][j]+=h[i-1][j]*(4*i-2);
                 if(h[i][j]>=10)
                   {
                       h[i][j+1]+=h[i][j]/10;
                       h[i][j]%=10;
                   }
             }
        len=h[i][len+1]==0?len:len+1;
        while(h[i][len]>=10)
         {
             h[i][1+len]=h[i][len]/10;
             h[i][len]%=10;
             len++;
         }
         int yu=0;
        for(int k=len;k>=1;k--)
        {
            int temp=(h[i][k]+yu*10)/(i+1);
            yu=(h[i][k]+yu*10)%(i+1);
            h[i][k]=temp;
        }
        while(!h[i][len])
            len--;
        h[i][0]=len;
    }
}
int main()
{
     int n;
     Catlan();
     while(~scanf("%d",&n))
       {
          for(int i=h[n][0];i>=1;i--)
            printf("%d",h[n][i]);
          printf("\n");
       }
     return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值