PAT-A1033 To Fill or Not to Fill 题目内容及题解

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

题目大意

开车从杭州出发要到达目的地,由于油箱容量有限,必须在路上加油。但是途中的加油站提供不同的价格,题目给出一系列数据,表示沿途加油站的油价与其位置,题目要求出最便宜的加油方案所需的价格。如果不能到达终点,那么需要求出最远可达的距离。

解题思路

  1. 先录入加油站信息,并依据距离进行排序(数据均使用double型);
  2. 如果第一个加油站位置非0则移动距离为0(边界条件之一);
  3. 贪心法:在每个加油站寻找最大可达距离中比当前油价低的加油站,或可达距离中油价最低的加油站作为下一次加油的目的地;
  4. 如果当前油价比目标油价高,则加油到恰好到达,否则加满油;
  5. 依次直到无法到达下一个点或者到达目的地;
  6. 输出结果并返回0值。

代码

#include<cstdio>
#include<algorithm>
#define maxn 510
#define INF 100000000
using namespace std;

struct St{
    double dis,price;
}Sat[maxn];

bool cmp(St a,St b){
    return a.dis<b.dis;
}

int N;
double C,D,Da;

int main(){
    int i,j,k;//k为当前站点 
    double remain=0,Max,fee,minprice,need;
    scanf("%lf%lf%lf%d",&C,&D,&Da,&N);
    for(i=0;i<N;i++){
        scanf("%lf%lf",&Sat[i].price,&Sat[i].dis);
    }
    Sat[N].dis=D;
    Sat[N].price=0.0;
    sort(Sat,Sat+N,cmp);
    if(Sat[0].dis!=0){
        printf("The maximum travel distance = 0.00\n");
    }else{
        k=0,fee=0.0,Max=C*Da,remain=0.0;
        while(k<N){
            i=-1,minprice=INF;
            for(j=k+1;j<=N&&Sat[j].dis-Sat[k].dis<=Max;j++){
                if(Sat[j].price<minprice){
                    i=j;
                    minprice=Sat[i].price;
                    if(minprice<Sat[k].price){
                        break;
                    }
                }
            }
            if(i==-1){
                break;
            }
            need=Sat[i].dis-Sat[k].dis;
            if(minprice<Sat[k].price){
                //只购买恰好的的油
                if(remain<need){
                    fee+=(need-remain)*Sat[k].price;
                    remain=0;
                }else{
                    remain-=need;
                }
            }else{
                fee+=(Max-remain)*Sat[k].price;
                remain=Max-need;
            }
            k=i;
        }
        if(k==N){
            printf("%.2lf\n",fee/Da);
        }else{
            printf("The maximum travel distance = %.2lf\n",Sat[k].dis+Max);
        } 
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值