【poj3278】Catch that cow——bfs

题目:

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 67806 Accepted: 21361

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


描述:在一维坐标x上,在坐标为i的点可以走到的点的坐标分别是x+1,x-1,2*x,给定起终点,求需要的时间

题解:每个点三种走法都记录一遍,如果没超过上限也没小于0就入队,并把这个点标记。注意要标记剪枝。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int Max = 100010;
int vis[Max];
int t[Max];
int n, k;

void bfs()
{
	int now, temp;
	queue<int> q;
	q.push(n);
	while (!q.empty())
	{
		now = q.front();
		q.pop();
		if (now == k)
		{
			cout << t[now] << endl;
			return;
		}

		for (int i = 1; i <= 3; i++)
		{
			if (i == 1)
			{
				temp = now + 1;
			}
			if (i == 2)
			{
				temp = now - 1;
			}
			if (i == 3)
			{
				temp = now * 2;
			}
			if (!vis[temp] && temp >= 0 && temp < Max)      //注意下界
			{
				vis[temp] = 1;                          //标记避免重复入队
				t[temp] = t[now] + 1;                   //走了一步产生一次消耗
				q.push(temp);
			}
		}
	}
}

int main()
{
	//freopen("input.txt", "r", stdin);
	while (scanf("%d%d", &n, &k) != EOF)
	{
		memset(vis, 0, sizeof(vis));             //初始化太短就不整出去了
		memset(t, 0, sizeof(t));
		bfs();
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值