Beans 二维化一维


                                           
  Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u    

Description

Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
 


 Now, how much qualities can you eat and then get ?

Input

There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output

For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input 

4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6 
       

Sample Output

242  

思路:开始想的直接用二维来写,根本不科学,早上起来想了下,发现  做完行dp,然后行就压缩了 最后再做一次列dp就出答案了,果然还是题刷太少反应太慢了,昨天晚上想到睡着都没想出来,行状态 和列状态一样dp[i]表示前i个数(一行或一列)能形成的最大和 然后考虑第i个选不选的问题 转移方程dp[i]=max(dp[i-2]+num,dp[i-1]);
复杂度 (列数+1)*行数
代码如下: 
//
// Create by 神舟 on 2015-02-13
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
using namespace std;

#define CLR(x) memset(x,0,sizeof x)
#define ll long long
#define inf 0x3f3f3f3f
const int maxn=2e5+5;
const int MOD=5e5+5;
int dp1[maxn],dp2[maxn],num;

int main()
{
#ifdef LOCAL
freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
#endif
ios_base::sync_with_stdio(0);

int n,m;
while(scanf("%d%d",&n,&m)!=EOF){
        CLR(dp1);//行变换存储数组
        CLR(dp2);//列变化(最后答案)存储数组
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf("%d",&num);
                if(j==1) dp1[j]=num;
                else dp1[j]=max(dp1[j-2]+num,dp1[j-1]);//行变化
            }
            if(i==1) dp2[i]=dp1[m];
            else dp2[i]=max(dp2[i-2]+dp1[m],dp2[i-1]);//列变换
        }
        printf("%d\n",dp2[n]);
}
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值