1143: [CTSC2008]祭祀river
Time Limit: 10 Sec Memory Limit: 162 MBSubmit: 2301 Solved: 1156
[ Submit][ Status][ Discuss]
Description
在遥远的东方,有一个神秘的民族,自称Y族。他们世代居住在水面上,奉龙王为神。每逢重大庆典, Y族都
会在水面上举办盛大的祭祀活动。我们可以把Y族居住地水系看成一个由岔口和河道组成的网络。每条河道连接着
两个岔口,并且水在河道内按照一个固定的方向流动。显然,水系中不会有环流(下图描述一个环流的例子)。
由于人数众多的原因,Y族的祭祀活动会在多个岔口上同时举行。出于对龙王的尊重,这些祭祀地点的选择必
须非常慎重。准确地说,Y族人认为,如果水流可以从一个祭祀点流到另外一个祭祀点,那么祭祀就会失去它神圣
的意义。族长希望在保持祭祀神圣性的基础上,选择尽可能多的祭祀的地点。
Input
第一行包含两个用空格隔开的整数N、M,分别表示岔口和河道的数目,岔口从1到N编号。接下来M行,每行包
含两个用空格隔开的整数u、v,描述一条连接岔口u和岔口v的河道,水流方向为自u向v。 N ≤ 100 M ≤ 1 000
Output
第一行包含一个整数K,表示最多能选取的祭祀点的个数。
Sample Input
4 4
1 2
3 4
3 2
4 2
1 2
3 4
3 2
4 2
Sample Output
2
【样例说明】
在样例给出的水系中,不存在一种方法能够选择三个或者三个以上的祭祀点。包含两个祭祀点的测试点的方案有两种:
选择岔口1与岔口3(如样例输出第二行),选择岔口1与岔口4。
水流可以从任意岔口流至岔口2。如果在岔口2建立祭祀点,那么任意其他岔口都不能建立祭祀点
但是在最优的一种祭祀点的选取方案中我们可以建立两个祭祀点,所以岔口2不能建立祭祀点。对于其他岔口
至少存在一个最优方案选择该岔口为祭祀点,所以输出为1011。
【样例说明】
在样例给出的水系中,不存在一种方法能够选择三个或者三个以上的祭祀点。包含两个祭祀点的测试点的方案有两种:
选择岔口1与岔口3(如样例输出第二行),选择岔口1与岔口4。
水流可以从任意岔口流至岔口2。如果在岔口2建立祭祀点,那么任意其他岔口都不能建立祭祀点
但是在最优的一种祭祀点的选取方案中我们可以建立两个祭祀点,所以岔口2不能建立祭祀点。对于其他岔口
至少存在一个最优方案选择该岔口为祭祀点,所以输出为1011。
HINT
Source
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<bitset>
#include<ext/pb_ds/priority_queue.hpp>
using namespace std;
const int maxn = 444;
const int maxm = 4E5 + 40;
const int INF = ~0U>>1;
struct E{
int to,cap,flow; E(){}
E(int to,int cap,int flow): to(to),cap(cap),flow(flow){}
}edgs[maxm];
int n,m,s,t,tot,cnt,A[maxn],B[maxn],cur[maxn],L[maxn];
bool vis[maxn];
vector <int> v[maxn];
queue <int> Q;
void Add(int x,int y,int cap)
{
v[x].push_back(cnt); edgs[cnt++] = E(y,cap,0);
v[y].push_back(cnt); edgs[cnt++] = E(x,0,0);
}
bool BFS()
{
for (int i = 0; i <= tot; i++) vis[i] = 0,L[i] = 0;
vis[s] = 1; L[s] = 1; Q.push(s);
while (!Q.empty())
{
int k = Q.front(); Q.pop();
for (int i = 0; i < v[k].size(); i++)
{
E e = edgs[v[k][i]];
if (e.cap == e.flow) continue;
if (vis[e.to]) continue;
vis[e.to] = 1; L[e.to] = L[k] + 1; Q.push(e.to);
}
}
return vis[t];
}
int Dinic(int x,int a)
{
if (x == t) return a;
int flow = 0;
for (int &i = cur[x]; i < v[x].size(); i++)
{
E &e = edgs[v[x][i]];
if (e.cap == e.flow) continue;
if (L[e.to] != L[x] + 1) continue;
int f = Dinic(e.to,min(a,e.cap - e.flow));
if (!f) continue;
e.flow += f;
edgs[v[x][i]^1].flow -= f;
flow += f;
a -= f;
if (!a) return flow;
}
if (!flow) L[x] = 0;
return flow;
}
int main()
{
#ifdef DMC
freopen("DMC.txt","r",stdin);
#endif
cin >> n >> m; t = ++tot;
for (int i = 1; i <= n; i++) A[i] = ++tot,B[i] = ++tot;
while (m--)
{
int x,y; scanf("%d%d",&x,&y);
Add(A[x],B[y],INF);
}
for (int i = 1; i <= n; i++)
Add(s,A[i],1),Add(B[i],t,1),Add(B[i],A[i],INF);
int MaxFlow = 0;
while (BFS())
{
for (int i = 0; i <= tot; i++) cur[i] = 0;
MaxFlow += Dinic(s,INF);
}
cout << n - MaxFlow;
return 0;
}