hdu_6186_前缀后缀_水_死于英语

CS Course
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,⋯,an, and some queries.

A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.
Input
There are no more than 15 test cases.

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2≤n,q≤105

Then n non-negative integers a1,a2,⋯,an follows in a line, 0≤ai≤109 for each i in range[1,n].

After that there are q positive integers p1,p2,⋯,pqin q lines, 1≤pi≤n for each i in range[1,q].
Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.
Sample Input
3 3
1 1 1
1
2
3
Sample Output
1 1 0
1 1 0
1 1 0

mean:
    给你a数组:
    求除了第i位 外所有数 &,|,^
    的值;
answer:
    求前缀后缀就好
#include<bits/stdc++.h>
using namespace std;
const int N=(int) 1e5+10;
int a[N],st1[N],st2[N],st3[N],ed1[N],ed2[N],ed3[N];
int main()
{
    int n,m,i,j;
    while(cin>>n>>m>>a[1])
    {
        st1[1]=st2[1]=st3[1]=a[1];
        for(i=2;i<=n;i++)
        {
            scanf("%d",&a[i]);
            st1[i]=st1[i-1]&a[i];
            st2[i]=st2[i-1]|a[i];
            st3[i]=st3[i-1]^a[i];
        }
        ed1[n]=ed2[n]=ed3[n]=a[n];
        for(i=n-1;i>=1;i--)
        {
            ed1[i]=ed1[i+1]&a[i];
            ed2[i]=ed2[i+1]|a[i];
            ed3[i]=ed3[i+1]^a[i];
        }
        while(m--)
        {
            int x; scanf("%d",&x);
            if(x==1)
                printf("%d %d %d\n",ed1[2],ed2[2],ed3[2]);
            else if(x==n)
                printf("%d %d %d\n",st1[n-1],st2[n-1],st3[n-1]);
            else
                printf("%d %d %d\n",st1[x-1]&ed1[x+1],st2[x-1]|ed2[x+1],st3[x-1]^ed3[x+1]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值