HDU - 1385 Minimum Transport Cost

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 
Input
First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 
Output
From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 

Sample Input
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0
Sample Output
From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17
 
 
题意就不在这叙述了,就是一个floyd + 打印路径;
这题的输出有点诡异,交了三发PE。
具体代码如下:
#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <string>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define inf 1<<30
#define eps 1e-10
#define maxn 0x3f3f3f3f
#define zero(a) fabs(a)<eps
#define Min(a,b) ((a)<(b)?(a):(b))
#define Max(a,b) ((a)>(b)?(a):(b))
#define pb(a) push_back(a)
#define mem(a,b) memset(a,b,sizeof(a))
#define LL long long
#define lson step<<1
#define rson step<<1|1
#define MOD 1000000009
#define sqr(a) ((a)*(a))
using namespace std;
int e[1005][1005];
int p[1005][1005];
int a[1005];
void init(int n) {
	for(int i = 1; i <= n; i++) {
		for(int j = 1; j <= n; j++) {
			if(e[i][j] == -1)
			 e[i][j] = maxn;
		}
	}
}
void floyd(int n) {
	for(int i = 1; i <= n; i++) {
		for(int j = 1; j <= n; j++) {
			p[i][j] = j;
		}
	}
	for(int k = 1; k <= n; k++) {
		for(int i = 1; i <= n; i++) {
			for(int j = 1; j <= n; j++) {
				int t = e[i][k] + e[k][j] + a[k];
				if(e[i][j] > t) {
					e[i][j] = t;
					p[i][j] = p[i][k];
				}
				else if(e[i][j] == t) {
					if(p[i][j] > p[i][k])
					p[i][j] = p[i][k];
				}
			}
		}
	}
}
int main() {
	int n;
	while(~scanf("%d",&n)&&n) {
		for(int i = 1; i <= n; i++) {
			for(int j = 1; j <= n; j++) {
				scanf("%d",&e[i][j]);
			}
		}
		for(int i = 1; i <= n; i++) 
		scanf("%d",&a[i]);
		init(n);
		floyd(n);
		int fr , to;
		while(~scanf("%d%d",&fr,&to)) {
			if(fr == -1 && to == -1)
			break;
			int end = fr;
			printf("From %d to %d :\n",fr,to);
			printf("Path: ");
			printf("%d",fr);
			while(end != to) {
				printf("-->%d",p[end][to]);
				end = p[end][to];
			}
			printf("\n");
			printf("Total cost : %d\n",e[fr][to]);
			printf("\n");
		}
	}
	return 0;
}

Accepted
Time31ms
Memory1952kB
Length1712
LangG++
Submitted
Shared
RemoteRunId23388578

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值