Find a way(bfs)

Problem:Find a way

Description:
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input:
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output:
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input:

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output:

66
88
66

Language:C++

#include <iostream>
#include <cstring>
#include <queue>
#define INF 0x3f3f3f

using namespace std;

const int N=201;

struct node
{
  int x;
  int y;
  int cnt;
}head,tail;

int m,n;
char s[N][N];
bool vis[N][N];
int cmp[2][N][N];

int step[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

void bfs(int x,int y,int k)
{
  queue<node>q;
  head.x=x;
  head.y=y;
  head.cnt=0;
  memset(vis,0,sizeof(vis));
  vis[x][y]=1;

  q.push(head);
  while(!q.empty())
  {
    head=q.front();
    q.pop();

    tail.cnt=head.cnt+1;
    for(int i=0;i<4;i++)
    {
      int tx=head.x+step[i][0];
      int ty=head.y+step[i][1];
      if(tx>=0&&tx<n&&ty>=0&&ty<m&&!vis[tx][ty]&&s[tx][ty]!='#')
      {
          if(s[tx][ty]=='@')  cmp[k][tx][ty]=tail.cnt;

          tail.x=tx;
          tail.y=ty;
          vis[tx][ty]=1;
          q.push(tail);
      }
    }
  }
}

int main()
{
  while(cin>>n>>m)
  {
    for(int i=0;i<n;i++)  cin>>s[i];

    memset(cmp,0,sizeof(cmp));
    for(int i=0;i<n;i++)
    {
      for (int j=0;j<m;j++)
      {
        if(s[i][j]=='Y') bfs(i,j,0);
        if(s[i][j]=='M') bfs(i,j,1);
      }
    }

    int ans=INF;
    for(int i=0;i<n;i++)
    {
      for(int j=0;j<m;j++)
      {
        if(cmp[0][i][j]&&cmp[1][i][j]) ans=min(ans,cmp[0][i][j]+cmp[1][i][j]);
      }
    }
    cout<<ans*11<<endl;
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值