【线段树】A Simple Problem with Integers

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 171549 Accepted: 52831
Case Time Limit: 2000MS
Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define lson node<<1
#define rson node<<1|1
int a[100005];
long long ans;
struct node
{
    int L,R;
    long long add,sum;
    int mid()
    {
        return (L+R)/2;
    }
    int len()
    {
    	return R-L+1;
	}
}tree[400050];
void build_tree(int start,int end,int node)
{
	tree[node].add=0;
	tree[node].L=start;
	tree[node].R=end;
	if(start==end)
	{
		tree[node].sum=a[start];
		return;
	}
	build_tree(start,tree[node].mid(),lson);
	build_tree(tree[node].mid()+1,end,rson);
	tree[node].sum=tree[lson].sum+tree[rson].sum;
}
void update_tree(int node,int l,int r,int add)
{
	if(tree[node].L>r || tree[node].R<l) return;
	if(tree[node].L>=l&&tree[node].R<=r)
	{
		tree[node].sum+=add*tree[node].len();
		tree[node].add+=add;
		return;
	}
	if(tree[node].add)
	{
		tree[lson].add+=tree[node].add;
		tree[lson].sum+=tree[node].add*tree[lson].len();
		tree[rson].add+=tree[node].add;
		tree[rson].sum+=tree[node].add*tree[rson].len();
		tree[node].add=0;
	}
	update_tree(lson,l,r,add);
	update_tree(rson,l,r,add);
	tree[node].sum=tree[lson].sum+tree[rson].sum;
}
void query_tree(int node,int l,int r)
{
	if(tree[node].L>r || tree[node].R<l) return;
	if(tree[node].L>=l&&tree[node].R<=r)
	{
		ans+=tree[node].sum;
		return;
	}
    if(tree[node].add)
	{
		tree[lson].add+=tree[node].add;
		tree[lson].sum+=tree[node].add*tree[lson].len();
		tree[rson].add+=tree[node].add;
		tree[rson].sum+=tree[node].add*tree[rson].len();
		tree[node].add=0;
	}
	query_tree(lson,l,r);
	query_tree(rson,l,r);
	tree[node].sum=tree[lson].sum+tree[rson].sum;
}
int main()
{
	int n,q;
	cin>>n>>q;
	for(int i=1;i<=n;i++)
	{
		cin>>a[i];
	}
	build_tree(1,n,1);
	char pd;
	int A,B,C;
	for(int i=0;i<q;i++)
	{
		cin>>pd;
		if(pd=='C')
		{
			cin>>A>>B>>C;
			update_tree(1,A,B,C);
		}
		else
		{
			ans=0;
			cin>>A>>B;
			query_tree(1,A,B);
			cout<<ans<<endl;
		}
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值