A Simple Problem with Integers +poj+线段树区间更新

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 59510 Accepted: 18127
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

解决方案:一样的模板题。

code:

#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX  100005
#define LL long long
using namespace std;
LL sum[4*MMAX];
LL addv[4*MMAX];
LL _sum,N,Q;
void build(int rt,int L,int R)
{

    if(L==R)
    {
        scanf("%lld",&sum[rt]);
        addv[rt]=sum[rt];
    }
    else
    {
        int M=(L+R)/2;
        build(rt*2,L,M);
        build(rt*2+1,M+1,R);
        sum[rt]=sum[rt*2]+sum[rt*2+1];///更新根节点
    }
}
void push_up(int rt,int L,int R)
{
    int lc=rt*2,rc=rt*2+1;
    sum[rt]=0;
    if(L<R)
    {
        sum[rt]=sum[rc]+sum[lc];

    }
    sum[rt]+=addv[rt]*(R-L+1);
}

void update(int rt,int L,int R,int sl,int sr,int c)
{

    if(sl<=L&&sr>=R)
    {
        addv[rt]+=c;
    }
    else
    {
        int M=(L+R)/2;
        if(sl<=M)update(rt*2,L,M,sl,sr,c);
        if(sr>M)update(rt*2+1,M+1,R,sl,sr,c);

    }
    push_up(rt,L,R);
}
void query(int rt,int L,int R,int ql,int qr,long long add)
{


    if(ql<=L&&qr>=R)
    {
        _sum+=sum[rt]+add*(R-L+1);
    }
    else
    {
        int M=(L+R)/2;
        if(ql<=M) query(rt*2,L,M,ql,qr,addv[rt]+add);
        if(qr>M) query(rt*2+1,M+1,R,ql,qr,addv[rt]+add);
    }

}
int main()
{
    char op;
    int a,b;
    LL c;
    while(~scanf("%lld%lld",&N,&Q))
    {
        memset(addv,0,sizeof(addv));
        build(1,1,N);
        for(int i=0; i<Q; i++)
        {
            getchar();
            scanf("%c",&op);
            if(op=='Q')
            {
                _sum=0;
                scanf("%d%d",&a,&b);
                query(1,1,N,a,b,addv[1]);
                printf("%lld\n",_sum);
            }
            else
            {
                scanf("%d%d%lld",&a,&b,&c);
                update(1,1,N,a,b,c);
            }
        }

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值