uva11997(优先队列,归并)

You’re given k arrays, each array has k integers. There are k
k ways to pick exactly one element in each
array and calculate the sum of the integers. Your task is to find the k smallest sums among them.
Input
There will be several test cases. The first line of each case contains an integer k (2 ≤ k ≤ 750). Each of
the following k lines contains k positive integers in each array. Each of these integers does not exceed
1,000,000. The input is terminated by end-of-file (EOF).
Output
For each test case, print the k smallest sums, in ascending order.
Sample Input
3
1 8 5
9 2 5
10 7 6
2
1 1
1 2
Sample Output
9 10 12
2 2

题目大意:有k个序列,每个序列有k个元素,问,每一个序列选一个元素,求出前k小的数并输出。
题目思路:
首先,暴力直接做是不行的,因为有k的k次方种选择的方法,经过刘汝佳的算法书,得到了一种很神奇的算法,就是先求得前两个序列的前k小的数,然后依次加入第三个序列,第四个序列,第四个序列,一直加到第k个序列,并把结果保存在第一个序列中。
真的很神奇。
然后,在求任意两个k小数中,可以通过优先队列的算法减低O(n2)的时间复杂度

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
using namespace std;
const int maxn = 750;
int a[maxn+10][maxn+10];
struct node
{
    int s,cnt;
    node(int s1,int cnt1){s=s1,cnt=cnt1;}
    bool operator<(const node& rhs)const
    {
        return s>rhs.s;
    }
};
void merge_(int *A,int *B,int *C,int k)
{
    priority_queue<node>q;
    for(int i=0;i<k;i++){
        q.push((node){A[i]+B[0],0});
    }
    int i=0;
    while(i<k){
        node top=q.top(); q.pop();
        C[i]=top.s;
        //cout<<C[i]<<endl;
        int cnt=top.cnt;
        if(cnt+1<k){
            q.push((node){C[i]-B[cnt]+B[cnt+1],cnt+1});
        }
        i++;
    }
}
int main()
{
    int n,cnt;
    while(~scanf("%d",&n)){
       for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            scanf("%d",&a[i][j]);
        }
        sort(a[i],a[i]+n);
       }
       for(int i=1;i<n;i++){
        merge_(a[0],a[i],a[0],n);
       }
       for(int i=0;i<n;i++){
        printf("%d%c",a[0][i],i==n-1?'\n':' ');
       }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值