hdu5980

Find Small A

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1140    Accepted Submission(s): 558


Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤  ai ≤2^32 - 1) follow
 

Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
 

Sample Input
      
      
3 97 24929 100
 

Sample Output
      
      
3
 


一开始没有看懂这道题,后来经过大佬的提醒明白了题意,a的ASCII码值是97,输入一个int类型的数字,在int范围内,即 32位拆成4个八位二进制的数字,让判断多少97,这道题充分说明位运算学的一塌糊涂,每次%2的8次方,看余数是否等于97,然后除以2的8次方。



#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;

int main()
{
    int n;
    std::ios::sync_with_stdio(false);
    cin>>n;int sum=0;
    while(n--){
        int a;
       cin>>a;
        while(a){
            if(a%256==97)
            {
                sum++;
            }
            a=(a>>8);
        }
    } cout<<sum<<endl;
    return 0;
}


 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值