算法笔记 Problem E: Shortest Distance

算法笔记 Problem E: Shortest Distance (20)

Description

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output

3
10
7
解释一下示例输入输出:第一行第一个代表输入几个数N,后面几个代表这N个数每两个之间的距离;第二行代表询问次数;剩余几行代表询问的哪两个点之间的距离

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=100005;//不太明白这为什么非要用100005???
int dis[MAXN],A[MAXN];//dis数组存的是1号节点按顺时针方向到达i+1号结点的距离,A数组存的是两个结点(i与i+1)直接的距离
int main(){
    int n,sum=0,query,left,right;
    scanf("%d",&n);//输入共几个距离
    for(int i=1;i<=n;i++){
        scanf("%d",&A[i]);
        sum+=A[i];//累加sum
        dis[i]=sum;//预处理dis数组,例如dis[1]存的是1->2的距离,dis[2]存的是1->3
    }
    scanf("%d",&query);
    for(int i=0;i<query;i++){
        scanf("%d%d",&left,&right);
        if(left>right)swap(left,right);//当left大于right时交换
        int temp=dis[right-1]-dis[left-1];
        printf("%d\n",min(temp,sum-temp));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值