算法笔记——Codeup Contest 100000575 Problem E Shortest Distance (20)

题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入
5 1 2 4 14 9
3
1 3
2 5
4 1
样例输出
3
10
7

代码

#include <cstdio>
#define maxn 100010							//最大出口数不超过100010 
#include <algorithm>						//取顺时针距离和逆时针距离中较小者输出 min函数 
using namespace std; 
int main () {
	int n,m,x,y,temp,a[maxn]={0} ;			//分别记录 出口数、录入出口对数、出口对的两头、数组a记录从1到其他出口的逆时针距离 
	scanf ("%d", &n) ;
	for (int i=1; i<=n; i++) {
		scanf ("%d", &temp) ;	
		a[i+1] = a[i]+temp ;				//得到a[2]到a[n+1]的值 加上初始数组为0 所以a[1]为0 
	}
	int total = a[n+1] ;					//total记录逆时针一圈的总路程 
	scanf ("%d", &m) ;	
	while (m--) {							//进行m次出口对之间距离的判断 
		int ans;
		scanf ("%d %d", &x, &y) ;			 
		if (x > y) {
			int e=x;
			x=y;
			y=e;					
		}									//交换 使得 x<=y 
		ans = min(total-a[y]+a[x], a[y]-a[x] );		//顺时针距离 逆时针距离 取小 
		printf ("%d\n", ans) ;				//输出 
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值