PAT 1002 A+B for Polynomials (25分)

PAT 1002 A+B for Polynomials (25分)

his time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1 a​N1 N2 aN2 … N​K aNK where K is the number of nonzero terms in the polynomial, N​i and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N​2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

#include<cstdio>
const int max_n=1010;
double a[max_n]={0};
int main(){
    int e,n,Count=0;
    double k;
    scanf("%d",&n);//几个多项式
    for(int i=0;i<n;i++){
        scanf("%d %lf",&e,&k);//输入对应幂次和对应系数
        a[e]+=k;//输入相同幂次的项数可能有多个,对应系数加和
    }
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d %lf",&e,&k);
        a[e]+=k;//将第一个多项式对应系数直接加到第二个多项式上
    }
    for(int i=0;i<max_n;i++){
        if(a[i]!=0){
            Count++;//统计非零多项式的个数
        }
    }
    printf("%d",Count);
    for(int i=max_n-1;i>=0;i--){
        if(a[i]!=0)printf(" %d %.1f",i,a[i]);//注意%d前面有一个空格,保证输出格式,最后一个输出后面不能有空格
    }
    return 0;

}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值