PAT 甲级 1002 A+B for Polynomials (25 分)

题目

输入有两行,表示A,B两个多项式

每一行的输入,K表示该多项式的项数。之后每一对中,前一个表示指数,后一个表示常数项

his time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

分析

每个指数对应的常数项,用一个double[ ]数组来表示

代码

#include<iostream>
#include<string.h>
#include<algorithm>
#include<sstream>
using namespace std;
const int maxn = 1005;
double poly[maxn];

int main()
{
    int k1 , k2;
    //memset(poly , 0 , sizeof(poly));

    cin >> k1;
    for(int i = 0 ; i < k1 ; i ++)
    {
        int p ;
        double e;
        cin >> p >> e;
        poly[p] += e;
    }

    cin >> k2;
    for(int i = 0 ; i < k2 ;i ++)
    {
        int p ;
        double e;
        cin >> p >> e;
        poly[p] += e;
    }
    int cnt = 0;
    for(int i = 0 ;i < maxn ;i ++)
    {
        if(poly[i]) cnt++;
    }
    cout << cnt ;

    for(int i = maxn; i >= 0; i--)
    {
        if(poly[i])
        {
            printf(" %d %.1f" , i , poly[i]);
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值