POJ2229 Sumsets 递推or完全背包

题目连接:http://poj.org/problem?id=2229

Sumsets

Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 26673 Accepted: 10093

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

递推

#include<iostream>
#include<cstdio>
using namespace std;
#define N 1000005
#define MOD 1000000000
#define LL long long
LL a[N];
int main()
{
	int n;
	scanf("%d",&n);
	a[0]=1, a[1]=1, a[2]=2;
	for(int i=3;i<=n;++i){
		a[i]=a[i-1];
		a[++i]=(a[i-1]+a[i/2])%MOD;
	}
	printf("%lld",a[n]);
	return 0;
}

完全背包

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 1000005
#define mod 1000000000
#define LL long long
int n, m, dp[N], c[30];
void init(){
    c[0]=1;
    for(int i=1; ;++i){
        c[i]=c[i-1]<<1;
        if(c[i]>N){
            m=i; break;
        }
    }
}
int main()
{
    init();
    while(~scanf("%d",&n)){
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=0;i<m;++i){
            if(c[i]>n) break;
            for(int v=c[i];v<=n;++v){
                dp[v]+=dp[v-c[i]];
                if(dp[v]>mod) dp[v]%=mod;
            }
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值