POJ 2536 D - Gopher II (二分图匹配)

Gopher II
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9043 Accepted: 3754

Description

The gopher family, having averted the canine threat, must face a new predator. 

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

Input

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output

Output consists of a single line for each case, giving the number of vulnerable gophers.

Sample Input

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

Sample Output

1
 
二分图匹配,将袋鼠和洞连边建图。
#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;

const int MAXN=1e5+10;
int n,m;
double s,v;
int a[MAXN];
pair<double,double> P[MAXN];
vector<int> G[MAXN];
int match[MAXN];
bool used[MAXN];

void add_edge(int u,int v)
{
    G[u].push_back(v);
    G[v].push_back(u);
}

bool dfs(int v)
{
    used[v]=true;
    for(int i=0;i<G[v].size();i++)
    {
        int u=G[v][i],w=match[u];
        if(w<0||!used[w]&&dfs(w))
        {
            match[v]=u;
            match[u]=v;
            return true;
        }
    }
    return false;
}

int bipartite_matching()
{
    int res=0;
    memset(match,-1,sizeof(match));
    for(int v=0;v<n+m;v++)
    {
        if(match[v]<0)
        {
            memset(used,0,sizeof(used));
            if(dfs(v)) res++;
        }
    }
    return res;
}

int main()
{
    while(~scanf("%d%d%lf%lf",&n,&m,&s,&v))
    {
        for(int i=0;i<n+m;i++)
            G[i].clear();
        double dis=s*v;
        for(int i=0;i<n+m;i++)
        {
            scanf("%lf%lf",&P[i].first,&P[i].second);
        }
        for(int i=0;i<n;i++)
            for(int j=n;j<n+m;j++)
        {
            if((P[i].first-P[j].first)*(P[i].first-P[j].first)+(P[i].second-P[j].second)*(P[i].second-P[j].second)<=dis*dis)
            {
                add_edge(i,j);
            }
        }
        cout<<n-bipartite_matching()<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值