第三次—W - A == B ?

W - A == B ?

Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

思路

1、有小数时,去掉小数后面多余的0
如:1.100与1.1000用strcmp比较结果为不等,需要去0
2、如小数点后面全为0,需要去小数点
如:1与1.00用strcmp比较结果为不等,去0后仍不等还需要去小数点

代码

#include<stdio.h>
#include<string.h>
int main(){
	char a[100000],b[100000];
	while(scanf("%s%s",a,b)!=EOF){
		int i;
		if(strchr(a,'.')){
			for(i=strlen(a)-1;a[i]=='0';i--)
			   a[i]='\0';
			if(a[i]=='.') a[i]='\0';
		}
		if(strchr(b,'.')){
			for(i=strlen(b)-1;b[i]=='0';i--)
			   b[i]='\0';
			if(b[i]=='.') b[i]='\0';
		}
		if(strcmp(a,b)==0) printf("YES\n");
		else printf("NO\n");
	} 
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值