SDUT 3258 山东省第六届ACM程序设计大赛——H Square Number

                        Square Number

Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
In mathematics, a square number is an integer that is the square of an integer. In other words, it is the product of some integer with itself. For example, 9 is a square number, since it can be written as 3 * 3.
Given an array of distinct integers (a1, a2, …, an), you need to find the number of pairs (ai, aj) that satisfy (ai * aj) is a square number.

输入
The first line of the input contains an integer T (1 ≤ T ≤ 20) which means the number of test cases.
Then T lines follow, each line starts with a number N (1 ≤ N ≤ 100000), then N integers followed (all the integers are between 1 and 1000000).

输出
For each test case, you should output the answer of each case.
示例输入

1
5
1 2 3 4 12

示例输出

2

#include <bits/stdc++.h>
#define LL long long
#define MAX 1001000

using namespace std;

int a[MAX],flag[MAX];

bool prim(int x)
{
    for(int i=2;i*i<=x;i++)
    {
        if(x % i == 0)
            return false;
    }
    return true;
}

LL Judge(int x)
{
    return x * (x-1) / 2;
}

int main()
{
    //freopen("in.txt","r",stdin);
    std::ios::sync_with_stdio(false);
    int T,n,b;
    int top = 0;
    for(int i=2;i*i<MAX;i++)
    {
        if(prim(i))
        {
            a[top++] = i * i;
        }
    }
    cin>>T;
    while(T--)
    {
        memset(flag,0,sizeof(flag));
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>b;
            for(int j=0;a[j]<=b && a[j];j++)
            {
                while(b % a[j] == 0)
                    b /= a[j];
            }
            flag[b]++;
        }
        LL ant = 0;
        for(int i=0;i<MAX;i++)
        {
            ant += Judge(flag[i]);
        }
        cout<<ant<<endl;
    }
    return 0;
}




















  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值