HDU5347 多校赛1005 MZL's chemistry

哈哈,还得靠惊人的记忆力啊

Problem Description
  
  
MZL define F(X) as the first ionization energy of the chemical element X Now he get two chemical elements U,V ,given as their atomic number,he wants to compare F(U) and F(V) It is guaranteed that atomic numbers belongs to the given set: {1,2,3,4,..18,35,36,53,54,85,86} It is guaranteed the two atomic numbers is either in the same period or in the same group It is guaranteed that xy
 

Input
  
  
There are several test cases For each test case,there are two numbers u,v ,means the atomic numbers of the two element
 

Output
  
  
For each test case,if F(u)>F(v) ,print "FIRST BIGGER",else print"SECOND BIGGER"
 

Sample Input
  
  
1 2 5 3
 

Sample Output
  
  
SECOND BIGGER FIRST BIGGER


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>

using namespace std;


int main()
{
    double F[] = {0,13.598,24.587,5.391,9.322,8.298,11.261,14.534,13.618,17.422,21.564,5.139,7.646,5.985,8.151,10.486,10.361,12.967,15.759,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,11.813,13.999,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,10.451,12.129,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,10,10.748};
    int u,v;
    while(~scanf("%d%d",&u,&v))
    {
        if(F[u]<F[v])
            printf("SECOND BIGGER\n");
        else
            printf("FIRST BIGGER\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值