poj 1094 Sorting It All Out

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

bool Map[50][50];
int du[50];
int n,m;
queue<int >que;

void Empty()
{
    while(!que.empty())
        que.pop();
}

int Topo()
{
    int test[30];
    int result = 1;
    for(int i=1;i<=n;i++)
        test[i] = du[i];
    for(int i=1;i<=n;i++)
    {
        int cont = 0;
        int pos;
        for(int j=1;j<=n;j++)
        {
            if(test[j] == 0)
            {
                cont++;
                pos = j;
            }
        }
        if(cont == 0)
            return 0;
        if(cont > 1)
            result = -1;
        que.push(pos);
        test[pos] = -1;
        for(int j=1;j<=n;j++)
        {
            if(Map[pos][j])
                test[j]--;
        }
    }
    return result;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(cin>>n>>m)
    {
        if(n == 0 && m == 0)
            break;
        memset(Map,false,sizeof(Map));
        memset(du,0,sizeof(du));
        char str[3];
        bool flag = false;
        int To;
        for(int i=1;i<=m;i++)
        {
            Empty();
            cin>>str;
            if(flag)
                continue;
            int a = str[0] - 'A' + 1;
            int b = str[2] - 'A' + 1;
            Map[a][b] = true;
            du[b]++;
            To = Topo();
            if(To == 0)
            {
                flag = true;
                printf("Inconsistency found after %d relations.\n",i);

            }
            else if(To == 1)
            {
                flag = true;
                printf("Sorted sequence determined after %d relations: ",i);
                while(!que.empty())
                {
                    int t = que.front();
                    printf("%c",t + 'A' - 1);
                    que.pop();
                }
                printf(".\n");
            }
        }
        if(To == -1)
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值