BestCoder Round #50 (div.2) 1001

24 篇文章 0 订阅
21 篇文章 0 订阅

Problem Description

AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule be punished.Each one who get a part of money would write down his ID on that part.

Input

There are multiply cases.For each case,there is a single integer n(1<=n<=1000) in first line.In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.

Output

Output ID of the man who should be punished.If nobody should be punished,output -1.

Sample Input
3
1 1 2
4
2 1 4 3
Sample Output
1
-1
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
#include <cmath>
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;

int a[10010];
int ha[10110];
int main()
{
    int n;
    while(cin>>n)
    {
        memset(ha,0,sizeof(ha));
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
            ha[a[i]]++;
        }
        int pos = -1;
        for(int i=0;i<n;i++)
        {
            if(ha[a[i]] > n/2)
            {
                pos = a[i];
                break;
            }
        }
        cout<<pos<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值