2015 ACM/ICPC Asia Regional Shenyang Online

1012 Largest Point

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4804    Accepted Submission(s): 881


Problem Description
Given the sequence A with n integers t1,t2,,tn . Given the integral coefficients a and b . The fact that select two elements ti and tj of A and ij to maximize the value of at2i+btj , becomes the largest point.
 

Input
An positive integer T , indicating there are T test cases.
For each test case, the first line contains three integers corresponding to n (2n5×106), a (0|a|106) and b (0|b|106) . The second line contains n integers t1,t2,,tn where 0|ti|106 for 1in .

The sum of n for all cases would not be larger than 5×106 .
 

Output
The output contains exactly T lines.
For each test case, you should output the maximum value of at2i+btj .
 

Sample Input
  
  
2 3 2 1 1 2 3 5 -1 0 -3 -3 0 3 3
 

Sample Output
  
  
Case #1: 20 Case #2: 0
 
各位童鞋千万注意,输入ti时也要用long long,比赛时wa 20+
#include <bits/stdc++.h>
#define LL long long
using namespace std;
LL t[5000010];
typedef struct node
{
    LL data;
    int id;
    bool operator <(const node &x)const
    {
        return data > x.data;
    }
} FF;
FF L[5000010],R[5001000];
int main()
{
    int T,n,a,b;
    int cas = 0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&a,&b);
        for(int i=0; i<n; i++)
        {
            scanf("%lld",&t[i]);
            L[i].data = t[i] * t[i] * a;
            R[i].data = t[i] * b;
            L[i].id = i;
            R[i].id = i;
        }
        sort(L,L+n);
        sort(R,R+n);
        LL ans;
        if(L[0].data > R[0].data)
        {
            ans = L[0].data;
            if(L[0].id != R[0].id)
                ans += R[0].data;
            else
                ans += R[1].data;
        }
        else
        {
            ans = R[0].data;
            if(L[0].id != R[0].id)
                ans += L[0].data;
            else
                ans += L[1].data;
        }

        printf("Case #%d: %lld\n",++cas,ans);
    }
    return 0;
}


1006 Fang Fang

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4656    Accepted Submission(s): 986


Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence F of strings.
F0 = f",
F1 = ff",
F2 = cff",
Fn = Fn1 + f", for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F , or nothing could be done but put her away in cold wilderness.
 

Input
An positive integer T , indicating there are T test cases.
Following are T lines, each line contains an string S as introduced above.
The total length of strings for all test cases would not be larger than 106 .
 

Output
The output contains exactly T lines.
For each test case, if one can not spell the serenade by using the strings in F , output 1 . Otherwise, output the minimum number of strings in F to split S according to aforementioned rules. Repetitive strings should be counted repeatedly.
 

Sample Input
  
  
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
 

Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1 Case #8: -1
Hint
Shift the string in the first test case, we will get the string "cffffcfffcff" and it can be split into "cffff", "cfff" and "cff".

#include <bits/stdc++.h>
using namespace std;
char s[1000000+10];
int pos[1000000+10];
int e;
int main()
{
    int tg;
    scanf("%d%*c", &tg);
    int len, i, j;
    int cnt=1;
    while(tg--)
    {
        gets(s);
        len=strlen(s);
        if(len==0)
        {
            printf("Case #%d: 0\n",cnt++);
            continue;
        }
        bool ss=true;
        for(i=0; i<len; i++)
        {
            if(s[i]!='c' && s[i]!='f')
            {
                ss=false;
                break;
            }
        }
        if(ss==false)
        {
            printf("Case #%d: -1\n", cnt++);
            continue;
        }
        bool ok=false;
        e=0;
        for(i=0; i<len; i++)
        {
            if(s[i]=='c')
            {
                ok=true;
                pos[e++]=i;
            }
        }
        if(ok==false)
        {
            if(len%2==0)
                printf("Case #%d: %d\n", cnt++, len/2);
            else
                printf("Case #%d: %d\n", cnt++, len/2+1);
        }
        else
        {
            if(e*2 > (len-e) )
                printf("Case #%d: -1\n", cnt++);
            else
            {
                pos[e]=len+pos[0];
                bool z=true;
                for(i=0; i<e; i++)
                {
                    if(pos[i+1]-pos[i]<=2)
                    {
                        z=false;
                        break;
                    }
                }
                if(z==false)
                    printf("Case #%d: -1\n", cnt++);
                else
                    printf("Case #%d: %d\n", cnt++, e);
            }
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值