山东省第一届ACM省赛 A SDUT 2151 Phone Number(暴力)

21 篇文章 0 订阅

Phone Number

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

We know that if a phone number A is another phone number B’s prefix, B is not able to be called. For an example, A is 123 while B is 12345, after pressing 123, we call A, and not able to call B.
Given N phone numbers, your task is to find whether there exits two numbers A and B that A is B’s prefix.

输入

 The input consists of several test cases.
 The first line of input in each test case contains one integer N (0<N<1001), represent the number of phone numbers.
 The next line contains N integers, describing the phone numbers.
 The last case is followed by a line containing one zero.

输出

 For each test case, if there exits a phone number that cannot be called, print “NO”, otherwise print “YES” instead.

示例输入

2
012
012345
2
12
012345
0

示例输出

NO
YES


#include <bits/stdc++.h>
using namespace std;
char str[1010][100100];
int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        bool flag = false;
        for(int i=0; i<n; i++)
        {
            scanf("%s",str[i]);
            if(!flag)
            {
                for(int j=0; j<i; j++)
                {
                    bool f = 0;
                    for(int e  = 0;  str[i][e] && str[j][e]; e++)
                    {
                        if(str[i][e] != str[j][e])
                        {
                            f = 1;
                            break;
                        }
                    }
                    if(!f)
                    {
                        flag = 1;
                        break;
                    }
                }
            }
        }
        if(flag)
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl;
    }
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值